Permission denied error

From: vladimir kalmykov <vvk88_at_nyahnyahspammersnyahnyah>
Date: Thu Aug 16 2012 - 07:26:20 MDT


I have a problem installing PyNGL on supercomputer.

I tried precompiled binaries of PyNGL and PyNIO, but computer has other version of software(for example, and, so that way is impossible for me.

I have limited rights on system, and therefore i cant wtite to global folders, like 'usr/lib".

I tried following steps:

1) Put precompiled NCL in folder '~/.local'

2) export NCARG_ROOT= ~/.local

3) cd PyNGL
    python install --home=~/.local

But inspite of '--home' option compiler tries copy something in /usr/bin:

running install_data
copying Ngl.pth -> /usr/lib/python2.6/site-packages
error: /usr/lib/python2.6/site-packages/Ngl.pth: Permission denied

What should i do to finish installation?

Thank you.

pyngl-talk mailing list
List instructions, subscriber options, unsubscribe:
Received on Thu Aug 16 07:26:36 2012

This archive was generated by hypermail 2.1.8 : Thu Sep 13 2012 - 15:38:36 MDT