[Nio] assigning to a string/char NetCDF variable does not work

From: Michael Decker <m.decker_at_nyahnyahspammersnyahnyah>
Date: Thu Jun 16 2011 - 03:09:56 MDT

Hi everyone,

I just noticed I don't manage to assign a string value to a non-scalar
string/char-typed variable in a NetCDF file using Nio. I could not find
any documentation on assignment of string values to NetCDF variables on
the Nio webpages but I am relatively sure that it has already worked
some time ago. (I can't be absolutely certain about that, though).
Assigning a string of len 1 to a scalar char variable works as expected
in straight-forward notation.
I attached a small script that reproduces the problem on our system
(Debian GNU/Linux stable). We're using Nio 1.4.0, which is the newest
version as far as I can tell.
I have tried a few alternative ways I thought might work (see commented
lines) without any luck. Does anyone have an idea how it could work or
if this is a bug in Nio?


Michael Decker
Forschungszentrum Jülich
Institut für Energie- und Klimaforschung - Troposphäre (IEK-8)
E-Mail: m.decker@fz-juelich.de
Forschungszentrum Juelich GmbH
52425 Juelich
Sitz der Gesellschaft: Juelich
Eingetragen im Handelsregister des Amtsgerichts Dueren Nr. HR B 3498
Vorsitzender des Aufsichtsrats: MinDirig Dr. Karl Eugen Huthmacher
Geschaeftsfuehrung: Prof. Dr. Achim Bachem (Vorsitzender),
Dr. Ulrich Krafft (stellv. Vorsitzender), Prof. Dr.-Ing. Harald Bolt,
Prof. Dr. Sebastian M. Schmidt

pyngl-talk mailing list
List instructions, subscriber options, unsubscribe:

Received on Thu Jun 16 03:10:06 2011

This archive was generated by hypermail 2.1.8 : Fri Jul 01 2011 - 15:48:33 MDT