Failed to import PyNIO from precompiled binary

From: Shi-Pei Hsu <hsushipei1_at_nyahnyahspammersnyahnyah>
Date: Mon Mar 17 2014 - 18:59:57 MDT

Dear all,

I downloaded pre-compiled version of PyNIO,


I moved the extracted files under /usr since I can find the same

packages") from the tar file.

To test the software, I got the following message

>>> import Nio
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "", line 63, in <module>
    from nio import *
ImportError: cannot open shared object file: No such file or

Then, I checked the dynamically linked libraries of "", it prints the
following => (0x00007fffd5dfe000) => /lib64/ (0x00007fbc450c7000) => not found => not found => not found => /lib64/ (0x00007fbc44ebe000) => not found => /lib64/ (0x00007fbc44bb5000) => /lib64/ (0x00007fbc448ae000) => /lib64/ (0x00007fbc44697000) => /lib64/ (0x00007fbc4447a000) => /lib64/ (0x00007fbc440bb000)
/lib64/ (0x000000345dc00000)

Then I tried to find the missing *.so files, for example,

$ locate libssl

One of the output is,


Is the "point 10" after .so means the version of libssl I have is "too new"
for the current PyNIO?

I also tried to locate other missing libs, like "" needs, but I have /usr/lib64/ in my
system. I don't whether they are the same issue or not.

P.S. The OS I'm running is the latest stable version of Fedora, Fedora 20
with kernel 3.13.6-200.fc20.x86_64

Thank you very much!!

Jack Hsu

pyngl-talk mailing list
List instructions, subscriber options, unsubscribe:
Received on Mon Mar 17 19:00:07 2014

This archive was generated by hypermail 2.1.8 : Mon Apr 14 2014 - 11:43:53 MDT